Joe's Beta thread

DAMN maintenance and repair thread; including Farkle Fests! :boohoo:
User avatar
juddspaintballs
DAMN Grand Poohba
Posts: 1525
Joined: Wed Nov 14, 2012 8:32 am
Contact:

Re: Joe's Beta thread

Post by juddspaintballs » Wed Jun 13, 2018 10:39 pm

Essentially a new bike at this point. Have you spent more than what it would have cost to buy a new one off the floor yet?
Jed Gregory
KTM 450 EXC

User avatar
gots_a_sol
DAMN Poohba
Posts: 804
Joined: Sat Jul 26, 2014 7:08 am
Contact:

Re: Joe's Beta thread

Post by gots_a_sol » Wed Jun 13, 2018 10:51 pm

juddspaintballs wrote:
Wed Jun 13, 2018 10:39 pm
Essentially a new bike at this point. Have you spent more than what it would have cost to buy a new one off the floor yet?
Well most of this stuff is mods I would have done to a new bike anyway. So while I am in the neighborhood of what a new race model would cost, it would be bone stock still.

For the record, I have NOT kept track of what I have spent on mods/upgrades. I'm sure the number is depressing :lol2:
-Joe.

GMER/WATR member
'17 Beta 250RR/RE
'09 Husky WR177

User avatar
gots_a_sol
DAMN Poohba
Posts: 804
Joined: Sat Jul 26, 2014 7:08 am
Contact:

Re: Joe's Beta thread

Post by gots_a_sol » Sat Jun 16, 2018 2:55 pm

2 custom spacers later and I can now use my Husky wheels on the rear. Fronts are next.

Image
-Joe.

GMER/WATR member
'17 Beta 250RR/RE
'09 Husky WR177

User avatar
J&J
DAMN Poohba
Posts: 975
Joined: Sat Jan 05, 2013 10:54 pm
Contact:

Re: Joe's Beta thread

Post by J&J » Tue Jun 19, 2018 8:38 am

:thumbup:

User avatar
gots_a_sol
DAMN Poohba
Posts: 804
Joined: Sat Jul 26, 2014 7:08 am
Contact:

Re: Joe's Beta thread

Post by gots_a_sol » Mon Jun 25, 2018 10:57 pm

Finally got a somewhat decent start in a hare scramble this year. Life is so much smoother when you aren't the last guy in line :lol2:


-Joe.

GMER/WATR member
'17 Beta 250RR/RE
'09 Husky WR177

User avatar
J&J
DAMN Poohba
Posts: 975
Joined: Sat Jan 05, 2013 10:54 pm
Contact:

Re: Joe's Beta thread

Post by J&J » Tue Jun 26, 2018 9:25 am

Nice riding Joe! Makes me want to do a Hare Scramble... My riding might not be quite as smooth though :jack:

User avatar
gots_a_sol
DAMN Poohba
Posts: 804
Joined: Sat Jul 26, 2014 7:08 am
Contact:

Re: Joe's Beta thread

Post by gots_a_sol » Wed Mar 20, 2019 8:23 pm

Dumped it hard at the greenbrier enduro this past weekend. Slightly bent the handle bar mounts.

Image

Image

Image

I almost had to cut the mount in half to get the bolts out but they finally worked free.


I wasn't sure on what all I was going to find damaged so I picked up a complete replacement from BRP which arrived today.

Image
Last edited by gots_a_sol on Wed Mar 20, 2019 9:11 pm, edited 1 time in total.
-Joe.

GMER/WATR member
'17 Beta 250RR/RE
'09 Husky WR177

User avatar
Marylander
DAMN Grand Poohba
Posts: 1285
Joined: Wed Oct 16, 2013 8:13 pm
Contact:

Re: Joe's Beta thread

Post by Marylander » Wed Mar 20, 2019 9:11 pm

Looks like you'll have to put more effort in to booger up the new setup. :cheers: Not quite as adjustable though.

User avatar
Bucho
DAMN Grand Poohba
Posts: 5378
Joined: Sat Mar 08, 2008 10:57 am
Contact:

Re: Joe's Beta thread

Post by Bucho » Thu Mar 21, 2019 8:03 am

Nice!
Suzuki DR650
Beta Xtrainer
Sherco 290 trials

User avatar
gots_a_sol
DAMN Poohba
Posts: 804
Joined: Sat Jul 26, 2014 7:08 am
Contact:

Re: Joe's Beta thread

Post by gots_a_sol » Mon Feb 17, 2020 4:34 pm

So I've been having an issue with the bike randomly running away full throttle since mid summer last year. Every time I think it is fixed, I go to a race and 5 minutes in she says F you and runs away again. This seems to have started up after baking it at Tough like RORR from a blown out coolant hose.

I noticed in a pic from a race after that that I was smoking a ton so I did a pressure test and it showed a leaking crank seal on the trans side, so that was replaced prior to the Sumter NEPG. And the problem persists.

I have the bike on the stand now and with it running, there is no change when spraying down the carb/engine with brake cleaner (was suggested maybe a bad intake boot).

Another suggestion was a damaged slide so I pulled that out and while the slide looks fine, the needle does not.

Image

I am not really sure what would cause this? Or if it may be the source of my problem? I mean it looks like the thing got sand blasted but the rest of the carb is spotless (haven't pulled the bowl off yet) as is the intake track and I try and do a reasonable job at maintaining air filters in my bikes.
Last edited by gots_a_sol on Mon Feb 17, 2020 6:21 pm, edited 1 time in total.
-Joe.

GMER/WATR member
'17 Beta 250RR/RE
'09 Husky WR177

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests